Network Maintenance
Incident Report for Truth Social
Resolved
This incident has been resolved.
Posted Jul 12, 2022 - 08:27 UTC
Monitoring
Truth Social is currently unavailable for network upgrades.
Posted Jul 12, 2022 - 08:03 UTC
This incident affected: IOS Application and Website Access.