Application launch traffic
Incident Report for Truth Social
Resolved
We have resolved the performance bottlenecks with new user registration and validation, and are working through the new user waitlist at an accelerated rate.
Posted Mar 02, 2022 - 16:32 UTC
Monitoring
We have stabilized the account creation process. We are working to increase the rate of new account creation.
Posted Feb 21, 2022 - 19:32 UTC
Update
We have continued to improve the performance of system components for account creation and are increasing rate limits for new account creation.
Posted Feb 21, 2022 - 17:38 UTC
Identified
Due to the overwhelming demand at launch, we are currently rate-limited on onboarding new users to the platform. We are working to increase signup capacity for onboarding and will continue to update this status as capacity increases.
Posted Feb 21, 2022 - 16:06 UTC
Investigating
Apple released the Truth Social application in the App Store at 23:00 20 February. The Truth Social application is online, although user creation is currently rate-limited during our rollout. We will expand capacity over the coming hours to enable more users to join Truth Social.
Posted Feb 21, 2022 - 04:24 UTC
This incident affected: IOS Application.