Image and video uploads are not working for some users
Incident Report for Truth Social
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 03:28 UTC
Investigating
We are currently investigating this issue.
Posted Feb 21, 2023 - 02:54 UTC
This incident affected: IOS Application and Website Access.