Pre Election Day site slowness

Incident Report for Truth Social

Resolved

Historic traffic and all is well.
Posted Nov 09, 2022 - 14:17 UTC

Monitoring

We've implemented the fix and are continuing to monitor for the next 24-48h. Some non-core services may be slower than usual during this monitoring period.
Posted Nov 08, 2022 - 02:58 UTC

Identified

We have identified the cause of tonight's site slowness and are currently implementing a fix.
Posted Nov 08, 2022 - 02:05 UTC

Investigating

We have noticed site slowness today, and we're working on identifying the specific cause and remediating it. As a reminder, Election Day is coming up -- please go out to vote!
Posted Nov 08, 2022 - 00:43 UTC
This incident affected: IOS Application and Website Access.