Duplicate welcome emails
Incident Report for Truth Social
Resolved
This incident has been resolved.
Posted Mar 10, 2022 - 16:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2022 - 22:37 UTC
Identified
We have identified that some users are receiving duplicate email welcome messages when approved to join Truth Social. We are reducing this to a correct single message per user on approval.
Posted Mar 09, 2022 - 22:34 UTC
This incident affected: IOS Application.