Slow Performance / Site Failing to Load
Incident Report for Truth Social
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 22:19 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 31, 2023 - 22:08 UTC
Monitoring
We are working on addressing a backend issue that is causing slow performance and the site failing to load for some users.
Posted Jan 31, 2023 - 22:08 UTC
This incident affected: IOS Application and Website Access.