truthsocial.com Web App outage

Incident Report for Truth Social

Resolved

This incident has been resolved.
Posted Jun 27, 2022 - 20:54 UTC

Update

We are continuing to investigate this issue.
Posted Jun 27, 2022 - 20:31 UTC

Investigating

We are currently investigating this issue.
Posted Jun 27, 2022 - 20:31 UTC
This incident affected: Website Access.