Application traffic interrupted by Cloudflare outage
Incident Report for Truth Social
Resolved
Service fully restored.
Posted Jun 21, 2022 - 07:42 UTC
Investigating
There appears to be a Cloudflare outage affecting Truth Social (web and mobile), as well as much of the rest of the Internet. No data is at risk; merely a disruption to incoming use of the site. We expect a swift resolution by the provider, and will update as we learn more.
Posted Jun 21, 2022 - 06:58 UTC
This incident affected: IOS Application and Website Access.